View Single Post

TyronWind's Avatar


TyronWind
10.15.2015 , 05:33 PM | #1
Hey, guys.

I just wanted to share the solution to a problem I've been having last couple of times I install SWTOR. All those launcher repair tools and stuff wasn't helping and if you're reading this, I assume you've done some research as well before getting here.

The Problem:
Your launcher will update itself normally and you will be able to login normally. The launcher will activate the BitRaider to download the game and the current patch; however, the BitRaider don't always work (it might be your firewall, operational system, whatever) and you can leave the launcher forever and it never actually start the download (you can tell if it's downloading or not by the download speed that should be on display at the bottom of the launcher).

Solutions (All cases are possible, so don't straight up discard them just because some of them didn't work for me. And they all assume that you have your game launcher close, so start doing that before trying this):

1) Download and run the repair tool available in this thread - http://www.swtor.com/community/showthread.php?t=419492
This one should solve any corrupt file damage by partial download or some other bug. It didn't helped me, but it's not that big of a file, so it's worth give it a shot.

2) Go to your swtor directory and open (with any txt editor) a file called launcher.setting. Change the lines
----- "PatchingMode": "{ \"swtor\": \"BR\" }" to "PatchingMode": "{ \"swtor\": \"SSN\" }"
----- "bitraider_disable": false to "bitraider_disable": true
Save the file and delete the BitRaider, Movie and Asset folders then start the launcher (if you just installed the game, it should only have the BitRaider folder). THIS is the solution that worked out for me and solve any problems that your firewall or anti-virus have with BitRaider. Pay attention to how each command looks like in the file, to make sure the syntax is correct.

3) The most obvious solution (that didn't worked for me, by the way) is re-install the game. This shouldn't fix anything the first solution won't fix, but I said I would put everything here so there you go

Hope this help everyone