View Single Post

bigopfer's Avatar


bigopfer
03.18.2014 , 06:42 PM | #167
For those of you who have been having issues getting stuck at the Galactic Starfighter screen after launching the game, I too was one of you. (see my post on the previous page of this thread).

I had to do what I did not want to do, delete the bitraid folder and then re-launch, re-download, and then I was able to play. Of course, that took over 24 hours, because for some damn reason the SWTOR patcher/launcher will cause my computer to freeze once in a while. So when I open it and leave it to download, I can come back 6 hours later to see it frozen.

Of course I am also thinking what you are all thinking: why the frack is this the way I am supposed to fix this company's problem? Why is the customer support, tech support, and service piss poor? Just look and see how many responses to this thread there have been lately...

Look at the responses too, and see that we are asked to basically just re-download and re-install the game and "it will work!"

HERE IS THE BEST PART! MY GAME IS NOT WORKING, AGAIN! When I open the launcher, it opens (well the "outline" of the launcher is seen" it sits there for like 4-5 seconds, and then closes. SO MY LAUNCHER WON'T LAUNCH.

Yes, I like this game. Yes I want to play it...when it works. No, I will never, ever, ever resub to this game ever again after this month. I want an MMO to play looks like I'm going to have to go back to WoW or try to grind out GW2...

Frustrated.