View Single Post

DataBeaver's Avatar


DataBeaver
07.14.2013 , 04:38 PM | #1
So there I was on my level 55 Sith Inquisitor, working on reducing the size of my quest log. I thought I'd do the Black Talon flashpoint that had been sitting there forever. Besides getting it out of my quest log, I also wanted to see what it was like. I breeze through the flashpoint as can be expected. At the end I decide to go to Korriban and look for the HK-51 component. Just as the ship is jumping to hyperspace, boom! Crash! I've encountered the same in the Esseles flashpoint, but (1) it's been a while since I did that so I forgot about it and (2) I didn't know the exact point on Black Talon where I need to alt-tab to avoid the crash.

The crash naturally robbed me of the mission completion. I decided to just delete it since I had already seen the flashpoint. It also gave me a good scare, as when I logged back in, all I got was a bright pink blob on the character selection screen. I found the quit button and restarted the game. Same thing. I then managed to find the play button by the first character, but the blob persisted ingame. Fearing I might need to spend half a day reinstalling, I tried rebooting Windows. That fortunately fixed it and I was able to get back to playing.

Seriously, this bug has been around for what, a year now? It isn't even listed in the known issues. If you can't figure out how to make the hyperspace sequence not crash, just remove the damn thing. Altering the visuals has to be better than having your game look buggy and unstable. After all, no one is going to see the current visuals due to the crash.