View Single Post

guardiandashi's Avatar


guardiandashi
05.24.2013 , 08:20 PM | #17
I will toss in my 2 cents that I know something changed 2 weeks ago IE on tuesday 5/7/2013

I will admit there was a hardware issue involved but bear with me.
and for the record. my system I7 960, 18GB tripple channel ram nvidia 460gtx win 7 ultimate
now regarding all that the last time I looked the requrements are:

What are the system requirements for the game?
Processor:

•AMD Athlon 64 X2 Dual-Core 4000+ or better
•Intel Core 2 Duo 2.0GHz or better
Operating System:

•Windows XP Service Pack 3 or later
RAM:

•Windows XP: 1.5GB RAM
•Windows Vista and Windows 7: 2GB RAM
Note: PCs using a built-in graphical chipset are recommended to have 2GB of RAM.
Star Wars: The Old Republic requires a video card that has a minimum of 256MB of on-board RAM as well as support for Shader 3.0 or better. Examples include:

•ATI X1800 or better
•nVidia 7800 or better
•Intel 4100 Integrated Graphics or better
DVD-ROM drive – 8x speed or better (required for installation from physical editions only)
Internet connection required to play.

from http://www.swtor.com/info/faq

so my system blows the requirements so hard its not even funny

with that in mind Something changed that turned up the requirements enough that attempting to launch the game was overloading my power supply and forcing a reboot crash. uninstalling and reinstalling the game fixed it (briefly) and then it started again, then I turned down the resolution and it worked until I replaced the power supply with a bigger one.(upgrading from 600w to 750w)

now I had been playing consistantly for a couple weeks or a month before that and activated my account from F2P to full a week or 2 before the issue, additionally my friend noticed a severe performance hit around the same time so don't get all "elitist" about it when someone is complaining about performance issues on a system that is a LOT over the recommended specs for the game.

oh and just as a FYI I have other games I had tested Diablo 3, the new xcom game etc and NONE of them caused the reboot garbage, it was exclusively swtor