View Single Post

SanDiegoFlyerFan's Avatar


SanDiegoFlyerFan
04.01.2013 , 11:18 PM | #1220
So, I've been a sub since the first month after launch, and I started seeing crashes after 1.4 patch - about once a month if that, no big deal. Then after the big server merge last year, they started happening more frequently - once a week maybe. After Free 2 Play update, the crashes came more often - every other day or so. Finally, the past 2 weeks, I've been getting several random crashes per day along with a few BSODs sprinkled in there. This weekend, I played for about 3 hours on 3/30/13 and got 3 crashes to desk top, one complete shut down and 2 "Blue Screens of Death". Tonight I tried logging on, and the graphics (after the load character screen) were just choppy, incomplete and full of lag (in a word, "unplayable")
I don't know what to do - all of my graphics card drivers are up to date, (running nvidia 540M on windows 7 sp1 64 - dell xps 15) Can't think of a reason why it works fine (other than crashes) one day, and choppy graphics the next. (even tried lowering the "quality" settings in preferences all the way "very low") I really want to get this figured out by 2.0 release, as I already pre-paid for that update. This is just frustrating as all hell... Just cant see continuing my sub if this is what I have to look forward to... It's gotten nothing but worse over the past year. I am really disappointed in the (apparent) lack of progress this game has shown on these issues over the past year or so.