View Single Post

Ratae's Avatar


Ratae
02.11.2013 , 02:54 PM | #28 This is the last staff post in this thread.  
Hello Alinna,

I’ve no idea what troubleshooting steps you have already taken, so apologies if this includes things you have already tried.
Please try the following:
  • Close the launcher
  • Rename the "Retailclient"-folder within your Star Wars™: The Old Republic™ installation (e.g. to "retailclient-backup")
  • Restart the client as administrator
  • Right after putting in your login information, click on the repair button in the bottom left corner.

  • Make sure that your anti-virus software and firewall are not blocking the launcher by removing and then re-adding swtor.exe and launcher.exe as exceptions to both.
  • Go to this location:
    C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic
    Here, if you find a folder called 'Patch', delete it please.
  • Run FixLauncher.exe (also in the above location) as administrator.

Should these steps not resolve your issue, please go to www.swtor.com/download and download the setup file again and run it. (Please run the file as Administrator and add an exception for SWTOR_setup.exe to your firewall and anti-virus software).

This will reinstall the Launcher, it will not download the game content again.

If the problem still persists, could I ask you to try the following to flush your DNS:

1.First hold the windows key on your keyboard and press the R key.
2.When the run window appears type CMD into the box and press enter.
3.When the CMD window opens type ipconfig /flushdns.

When you have done this correctly, you should see the message "Successfully flushed the DNS resolver cache".


Please let us know how you get on.

Thank you for your cooperation.
Ratae | BioWare Customer Service - Forum Support