View Single Post

Kinado's Avatar

01.27.2013 , 02:09 PM | #1
SWTOR gave me A LOT of trouble to make it run perfectly 60+FPS constant and without jaggies but I eventually made it!

My system spec is:
windows 7 64 bit
gtx 680 SC
i5 2500K @ 4.3

I play at 1920x1080p with a 120hz monitor. Everything is maxed besides in-game AA, Anisotropic Filtering and Vsync which are turned OFF. Now that you know with what I play you can adjust the settings to your liking comparing to mine.

Got Jaggies all over the place? Sudden FPS drops where there shouldn't be none? Turning your camera makes the game "skip" a few frames giving a stutter feeling? Maybe I can help.

I've seen a lot of posts of people with GTX 680 (not only) getting low FPS so I hope this will help them.

1st you need to download and install Nvidia Inspector. Google it if you don't have it already . Open the Star Wars: The Old Republic profile and make sure it looks like this:

You can see my nvidia inspector version as my Graphics Card Drivers (310.64) on the top left corner just in case.

_Pay attention to the Anti-aliasing compatibility as the flag for it isn't the same you ll find with a quick search for SGSSAA. I found this one to be faster for Sparse Grid Supersampling (SGSSAA): 0x000012C1 .

_ 4x [4x Multisampling] with 4x Sparse Grid Supersampling makes SWTOR look like a constant screenshot, with absolutely NO JAGGIES. Looks amazing and i m a graphics kind of guy.

_Anisotropic Filtering is set at 8x but you can set it at 16x, I just prefered the extra FPS boost 8x gave me since visually there is little difference.

_Texture Filtering LOD BIAS at: -1.000 . It will make the game's texture look shiny, as if it was reflecting the environment. Specially heavy plate armors look great with this. If you put at -3.000 it will be a shiny festival but it costs more performance also. -1.000 looks great.

_Set the Texture Filtering Negative LOD bias to: ALLOW to let all the shiny happen

_One VERY IMPORTANT setting that I found that "saved" my FPS was Maximum pre-rendered frames set to: 1.
I played with great FPS in the fleets full of people and in warzones, but some zones like dormund Kaas and Voss( didn t try more places), my FPS went from 100+ to +/- 30 in some places. Very strange, makes me think the game is very poorly optimized. Setting the max pre-rendered frames to 1 fixed that for me.

_Force Vsync OFF just to make sure. I've read it causes people problems and the tearing without it is almost non existing.

_Also triple buffering Off since you won't be using Vsync to start with.

_After you applied your settings don't forget th Press the Green button on the top right corner to "Apply Changes".

Make sure in-game Vsync and Anti-Aliasing is turned off. Go to your SWTOR .ini file located probably at yourusername/Appdata/Local/SWTOR/settings. You might have to make it show hidden folders to see the Appdata folder. Select client_settings ini and delete any anti-aliasing line if you have any.

I also made my swtor.exe to run under compatibility with windows XP SP 3, don t know if it makes any difference but since I made that change a while ago, doesn't hurt to try and do the same.

Make sure you try my exact same nvidia inspector settings as it's easy to overlook one setting and screws your whole FPS'. If the 4x AA is too much try a little less but with anything less jaggies will show in a 1080p resolution.

It took me a long time to make this game run perfectly fluid and with amazing visuals without any F*IN JAGGIES FFS!!! Made me quit my subscription before because I wasn't able to pull it off, now I did it so I subscribed again. The game is great and if you can make it work as I did, your gameplay and graphics will be amazing. Good luck and enjoy.

PS: I also use a program to cap my FPS to 61. The name is Dxtory . Download it, install it, on the Advanced tab ( 8th from the left i think), choose the FPS you want to limit SWTOR.exe to. You can choose the swtor.exe from the dropdown menu on top.