View Single Post

OwenBrooks's Avatar


OwenBrooks
01.14.2013 , 05:00 AM | #688
Quote: Originally Posted by geemorin View Post
FIX that worked for me:

Context for Bioware:
I had crashes to desktop in this game and also in TF2. Crashes were occurring in the same DLL. I realized that my TF2 crashes started right after I activated the "Multi-Core Rendering Optimization" option. So I disabled it and it stopped crashing to desktop. So I thought it my be the same for SWTOR and actually, it was the same problem. Since I haven't seen this option in the Video preferences menu, I forced a single core rendering for all my applications through my NVidia settings panel. Multi-core rendering on some machines tends to cause memory leaks or shared memory problems for some obscure reasons...

To de-activate "Multi-Core Rendering" with NVidia:
  1. Right-click on your desktop background
  2. Select "NVidia settings"
  3. Go in the "Manage 3D settings" option
  4. Under the "Global Settings" tab
  5. Find the "Threaded optimization" option and turn it "OFF" to force it off.
  6. Also make sure that all applications under the "Program Settings" tab uses the "Global Settings" for this option.
  7. Apply the modifications
  8. Enjoy

I hope this works for you!

A less disappointed user!
I wonder why this is only affecting some 64 bit and not others, i wonder if this will affect 32bit OS as well hmm.

Or is it only certain cards like the 500 series, good to know you stopped your crashes and thank you for sharing this information as it may indeed help others with crashing.

Edit - Was your crash still only specific to the end of flashpoints ?