View Single Post

UberBatman's Avatar


UberBatman
12.11.2012 , 10:03 PM | #1
I tried submitting a ticket for this yesterday but still haven't received a response for this so hopefully someone here can help me. I'm an Imperial Agent and to complete the task Destroy the Enemy (the last class one on Balmorra) I need to use the ships holoterminal. The problem is when I right click on the holoterminal the screen goes black for a second and acts like its going to load a conversation and then I'm just left with my agent looking at watcher 2 and nothing happening. If i push right or left the camera spins around but there isn't any conversation going on. I've tried hitting space bar, flying around to different planets and trying the holo, and closing out and restarting the game. In the mean time of me waiting for customer service to get back to me about this I went to Nar Shaddaa and completed all the class missions there. I am now completely stuck since I need to use the holoterminal to complete Destroy the Enemy which is currently impossible. Can someone please help me?