View Single Post

Bredwyn's Avatar


Bredwyn
12.10.2012 , 04:42 PM | #8
Quote: Originally Posted by Demetriscy View Post
Fix #3: Note: This is the best fix which worked for me, it provided the most smoothest experience. If you have an nVidia GPU, go to "manage 3D settings" > "Program Settings" > "Add" (find the swtor.exe from the installed directory) > "Maximum pre-rendered frames = 1" > "Multi-display/mixed-GPU acceleration = Single display performance" > "Power management mode = Prefer maximum performance" > "Triple buffering = ON". The rest of the settings should be left as Default. Make sure you have max-prerendered frames on "1" and Triple buffering = ON as this is what I suspect is making the game run smooth.
Worked for me too, thanks a lot!