View Single Post

Zoozy's Avatar


Zoozy
12.05.2012 , 12:02 PM | #9
why i should use some tests if i download 1.5.0 client and re-install it.

I play swtor 4-5 month from release and start play month ago. I never have problems before with downloading but with 1.5.2 patch i can't update. You think many people can't download your update because our computers is bad?
There is only one solution for this issue - RE-INSTALL CLIENT. You can put in archive client 1.5.0 or older and if you have some issues - re-install. it's more faster than your answers.
Zoozy Sith Marauder <Za Drots> Tomb of Freedom Nadd