View Single Post

isigrl's Avatar


isigrl
12.02.2012 , 05:25 AM | #3
Quote: Originally Posted by JerumyRoph View Post
The problem:
There seems to be some consensus that the people experiencing this issue started with one crafting skill then switched to another. For example, I picked Armstech first then switched to Armormech. Now when I reverse engineer Armormech equipment and learn the next tier schematic from it, I can craft the learned schematic until I logout. After next log in the recipe is gone and I can no longer craft the higher tier item. It may be helpful to note that my other toons are not affected by this.

So in lieu of a solution from the powers that be, I have a couple of questions for people experiencing this issue:
a) Did you switch crafting skills and now experience this?
b) Have you tried switching back to the original skill and can now keep schematics learned by RE?
c) Do we have to start a new toon to get the crafting skill we want and be able to keep learned schematics or are all new toons since 1.5 affected by this?

Thanks.
a) Yes and no. It's a tricky bug.
On my jedi knight main that switched skills at the very beginning of the game, I can't keep the new schematics if they are learned by reverse engineering. However, I do keep those bought from the GTN (crafting schematics only, crafting missions bought from the GTN dissapear in the same manner).
On my alts that had never switched skills, I can keep all schematics learned from reverse engineering, no problem there. However, I cannot learn new crafting mission schematics bought from the GTN or aquired on other crafting missions (such as slilcing, treasure hunting, etc). This last bug is present on all my toons.
So it seems like the bug is affecting schematics for crafing items and crafting missions as well.

b) Yes, even after switching skills back, it still doesn't stick (new schematics disappear)

c) In my experience all toons, new and old are affected by this, since 1.5 [as described -> a)]

(Also - if I remember correctly, this is actually an old bug, that was already fixed at some point.)