View Single Post

Asharic's Avatar


Asharic
11.23.2012 , 04:09 PM | #725
The problem I've been having is as follows:

1. When I click on 'PLACE YOUR ORDER' yellow clicky on the SWTOR website, either through the game or net....NOTHING happens. No refresh, no loading the next page, not even a URL when I hover my cursor or clicking on it. It looks like a dead link.

I've yet to see anyone post a similar description of the problem so I was wondering if I was alone here? ^

2. I've tried updating my data that BW/EA has had since well before Beta but NOTHING happens...it says saved but when try to purchase on the $Store it still shows my old address.

I HAVE tried all the recommended fixes with negative results. I have posted several replies to this thread lambasting the amateur decision to go on leave post a major update; but, since it is readily apparent no one at their company cares enough to deign a response there is no point to continue other than to vent my frustration.

I will say this however...One would think you'd WANT our money...I'm guessing not.
Bjoric Zell,
The Jedi Order "Fear none, Respect all."