View Single Post

Atrimentus's Avatar

11.21.2012 , 03:28 PM | #6
Try disabling Bloom. If that doesn't do it, go to the task manager and right click on the two swtor.exe process and Set Priority to "High" or "Above Normal." I have a HD 7850 and I was getting <30 FPS in all settings (maxed and lowest) but after setting the priority to high my FPS improved dramatically.