View Single Post

Philastra's Avatar


Philastra
10.04.2012 , 10:48 AM | #10
Quote: Originally Posted by Skylerr View Post
Completely, 100%, false.

I am not experiencing any significant amount of network lag nor were any of the dozens of people I played with yesterday while I was going through pug flashpoints (I've been asking about this stuff because folks on the forum are under the impression everyone is having issues). A few people on the forums complaining does not equal everyone. Vast numbers? There are a few dozen people talking about each issue on the forums (of which there are like 3 or 4 people that appear to make most of the posts... repeating the same stuff over and over...)... I was just on Dromund Kaas with 190 players that were apparently not experiencing any game breaking issues at all I (on just my server, of course). I have 4 computers with SWTOR installed (one 30 miles from the others) and none of them are experiencing issues post 1.4.

The fact that people don't usually come to the forums to say "hey, everything working great over here" doesn't mean everyone is experiencing technical issues...
Why do seem to like to troll the CS forums ppl come here for help ,leave if all your gonna do is disagree, if someone is having a problem and they post it here they are for solutions not a forum troll who if you look at your post history its obvious that what you do ..troll the CS forums go play the game and get outta here.
It only takes one candle to scare away the dark, or just hire a Bounty Hunter....