View Single Post

Cerimon's Avatar

09.13.2012 , 12:46 PM | #4 Click here to go to the next staff post in this thread. Next  
Greetings west_tell,

One of the more common causes of this issue seems to be having a language other than English (United States) set as the fallback language in your Windows preferences. If you're running Windows 7, this can be set from the 'Region and Language' control panel go to the Administrative tab and make sure the 'Current language for non-Unicode programs' is set as 'English (United States)' -- if that's not the setting, change it and try running again.

Please confirm your Windows user account name does not contain extended characters (accented characters, Greek characters, Cyrillic characters etcetera).
If it does you might have to create a second administrator account using only basic numbers/letters.

Please try removing and re-adding the following files to your anti-virus and firewall exceptions:

C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\launcher.exe

and swtor_setup.exe

Please let us know if the issue persists.

Cerimon | BioWare Customer Service - Forum Support