View Single Post

Hutchison's Avatar

12.15.2011 , 08:08 PM | #1
I've played 2 test weekends so far and the game ran beautifully. I had no errors and my FPS were usually 65-85. Well I got invited to Early Game Access and I was so excited. I completely removed all the beta software and reinstalled to be safe for launch. Well now, when I download the 38M swtor.exe to initially setup the game it says simply,

"Star Wars: The Old Republic can not be installed in this version of Windows. Please check the system requirements. Would you like to continue installation?"

I have read the reqs... It says that Windows XP is fine.
I checked my windows version in system and it's XP Home - Version 2002 - SP2.
I ran all my windows updates and that's the best that was available, apparently.
At first, I told the game to install anyway, and when I logged in & clicked Play I got an error relating to movie playback so I had to download Quicktime. That solved the error problem and the game started finally, but as soon as video switched to the game, the monitor would lose signal and I could hear, but not see the gameplay, resulting in me having to ALT+F4 back to Windows.

The thing is, of course, why did beta work just fine and now this for the actual game?
What am I missing? The launcher doesn't tell me what I NEED; it's just telling me what I CAN'T use now.

Would greatly appreciate any help that anyone could offer.
P.S. Intel Core i7 920 CPU, mobo: ASUS Rampage II Gene, 2G Corsair RAM and GTX295 Video Card.