View Single Post

Azashi's Avatar

01.15.2012 , 04:35 PM | #1
This has got to be some kind of joke, right?

How long has the game been out and still this bug has yet to be fixed...

We thought that it may have been our rotations, tried that... didnt work. Then we thought that both teams has to do it simultaneously, tried that... guess what... didnt work.

Both guild 8man raid teams had the exact same problems, completed 2nd stage then were not able to click the buttons anymore...

What a waste of 90minutes of my life and that of my guild mates.

P.S. I have absolutely no doubt that if by some miracle we did manage to complete this encounter, that the loot chest would bug as per usual.

P.S.S. For those of you confused as to why your Gharj quest had not been completed although you had dropped the boss, its another bug which as far as we can see is because you were in the last 4 within the raid. The 1st group (1st 4 members of the raid) would have completed it but for those of you within the 2nd group, you will have to wait until next week. GG

Kind regards,

Your one of many slighty p****d customers.